Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. ckeditor5
  4. ›
  5. CVE-2022-48110

CVE-2022-48110: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

February 13, 2023 (updated February 14, 2023)

CKSource CKEditor5 35.4.0 was discovered to contain a cross-site scripting (XSS) vulnerability via the Full Featured CKEditor5 widget.

References

  • ckeditor.com/docs/ckeditor5/latest/features/html-embed.html
  • github.com/advisories/GHSA-6p89-3p7c-qrhv
  • nvd.nist.gov/vuln/detail/CVE-2022-48110
  • packetstormsecurity.com/files/170927/CKSource-CKEditor5-35.4.0-Cross-Site-Scripting.html

Code Behaviors & Features

Detect and mitigate CVE-2022-48110 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 36.0.0

Fixed versions

  • 36.0.0

Solution

Upgrade to version 36.0.0 or above.

Impact 6.1 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Source file

npm/ckeditor5/CVE-2022-48110.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:28 +0000.