Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. ckeditor4
  4. ›
  5. CVE-2022-24729

CVE-2022-24729: Improper Input Validation

March 16, 2022 (updated November 7, 2023)

CKEditor4 is an open source what-you-see-is-what-you-get HTML editor. CKEditor4 prior to version 4.18.0 contains a vulnerability in the dialog plugin. The vulnerability allows abuse of a dialog input validator regular expression, which can cause a significant performance drop resulting in a browser tab freeze. A patch is available in version 4.18.0. There are currently no known workarounds.

References

  • ckeditor.com/cke4/release/CKEditor-4.18.0
  • github.com/ckeditor/ckeditor4/security/advisories/GHSA-f6rf-9m92-x2hh
  • nvd.nist.gov/vuln/detail/CVE-2022-24729
  • www.drupal.org/sa-core-2022-005

Code Behaviors & Features

Detect and mitigate CVE-2022-24729 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 4.0 before 4.18.0

Fixed versions

  • 4.18.0

Solution

Upgrade to version 4.18.0 or above.

Impact 7.5 HIGH

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Learn more about CVSS

Weakness

  • CWE-1333: Inefficient Regular Expression Complexity

Source file

npm/ckeditor4/CVE-2022-24729.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:37 +0000.