Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. ckeditor4
  4. ›
  5. CVE-2021-32808

CVE-2021-32808: Cross-site Scripting

August 12, 2021 (updated November 7, 2023)

ckeditor is an open source WYSIWYG HTML editor with rich content support. A vulnerability has been discovered in the clipboard Widget plugin if used alongside the undo feature. The vulnerability allows a user to abuse undo functionality using malformed widget HTML, which could result in executing JavaScript code. It affects all users using the CKEditor 4 plugins listed above at The problem has been recognized and patched. The fix will be available

References

  • nvd.nist.gov/vuln/detail/CVE-2021-32808

Code Behaviors & Features

Detect and mitigate CVE-2021-32808 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 4.13.0 before 4.16.2

Fixed versions

  • 4.16.2

Solution

Upgrade to version 4.16.2 or above.

Impact 5.4 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Source file

npm/ckeditor4/CVE-2021-32808.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:29 +0000.