Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. ckeditor4
  4. ›
  5. CVE-2020-9440

CVE-2020-9440: Cross-site Scripting

March 10, 2020 (updated March 29, 2020)

A cross-site scripting (XSS) vulnerability in the WSC plugin through allows remote attackers to run arbitrary web script inside an IFRAME element by injecting a crafted HTML element into the editor.

References

  • nvd.nist.gov/vuln/detail/CVE-2020-9440

Code Behaviors & Features

Detect and mitigate CVE-2020-9440 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

Version 4.0

Fixed versions

  • 4.13.0

Solution

Upgrade to version 4.13.0 or above.

Impact 6.1 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Source file

npm/ckeditor4/CVE-2020-9440.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:45 +0000.