Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. ckeditor4
  4. ›
  5. CVE-2020-27193

CVE-2020-27193: Cross-site Scripting

November 12, 2020 (updated December 2, 2021)

A cross-site scripting (XSS) vulnerability in the Color Dialog plugin for CKEdit allows remote attackers to run arbitrary web script after persuading a user to copy and paste crafted HTML code into one of editor inputs.

References

  • ckeditor.com/blog/CKEditor-4.15.1-with-a-security-patch-released/
  • ckeditor.com/cke4/release/CKEditor-4.15.1
  • ckeditor.com/ckeditor-4/download/
  • nvd.nist.gov/vuln/detail/CVE-2020-27193

Code Behaviors & Features

Detect and mitigate CVE-2020-27193 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

Version 4.15.0

Fixed versions

  • 4.15.1

Solution

Upgrade to version 4.15.1 or above.

Impact 6.1 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Source file

npm/ckeditor4/CVE-2020-27193.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:12 +0000.