Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. brace-expansion
  4. ›
  5. CVE-2017-18077

CVE-2017-18077: Improper Input Validation

January 29, 2018 (updated September 3, 2021)

index.js in brace-expansion before 1.1.7 is vulnerable to Regular Expression Denial of Service (ReDoS) attacks, as demonstrated by an expand argument containing many comma characters.

References

  • bugs.debian.org/862712
  • github.com/advisories/GHSA-832h-xg76-4gv6
  • github.com/juliangruber/brace-expansion/issues/33
  • github.com/juliangruber/brace-expansion/pull/35
  • github.com/juliangruber/brace-expansion/pull/35/commits/b13381281cead487cbdbfd6a69fb097ea5e456c3
  • nodesecurity.io/advisories/338
  • nvd.nist.gov/vuln/detail/CVE-2017-18077
  • www.npmjs.com/advisories/338

Code Behaviors & Features

Detect and mitigate CVE-2017-18077 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 1.1.7

Fixed versions

  • 1.1.7

Solution

Upgrade to version 1.1.7 or above.

Impact 7.5 HIGH

CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Learn more about CVSS

Weakness

  • CWE-20: Improper Input Validation

Source file

npm/brace-expansion/CVE-2017-18077.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:49 +0000.