Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. bootstrap-select
  4. ›
  5. CVE-2019-20921

CVE-2019-20921: Cross-site scripting in bootstrap-select

May 7, 2021 (updated November 25, 2024)

bootstrap-select before 1.13.6 allows Cross-Site Scripting (XSS). It does not escape title values in OPTION elements. This may allow attackers to execute arbitrary JavaScript in a victim’s browser.

References

  • github.com/advisories/GHSA-7c82-mp33-r854
  • github.com/snapappointments/bootstrap-select
  • github.com/snapappointments/bootstrap-select/commit/ab6e068748040cf3cda5859f6349b382402b8767
  • github.com/snapappointments/bootstrap-select/issues/2199
  • issues.jtl-software.de/issues/SHOP-7964
  • nvd.nist.gov/vuln/detail/CVE-2019-20921
  • snyk.io/vuln/SNYK-JS-BOOTSTRAPSELECT-570457

Code Behaviors & Features

Detect and mitigate CVE-2019-20921 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 1.13.6

Fixed versions

  • 1.13.6

Solution

Upgrade to version 1.13.6 or above.

Impact 6.1 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Source file

npm/bootstrap-select/CVE-2019-20921.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:17:27 +0000.