Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. basic-ftp
  4. ›
  5. GHSA-rp42-5vxx-qpwr

GHSA-rp42-5vxx-qpwr: basic-ftp vulnerable to denial of service via unbounded memory consumption in Client.list()

April 16, 2026

basic-ftp@5.2.2 is vulnerable to denial of service through unbounded memory growth while processing directory listings from a remote FTP server. A malicious or compromised server can send an extremely large or never-ending listing response to Client.list(), causing the client process to consume memory until it becomes unstable or crashes.

References

  • github.com/advisories/GHSA-rp42-5vxx-qpwr
  • github.com/patrickjuchli/basic-ftp
  • github.com/patrickjuchli/basic-ftp/security/advisories/GHSA-rp42-5vxx-qpwr

Code Behaviors & Features

Detect and mitigate GHSA-rp42-5vxx-qpwr with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 5.3.0

Fixed versions

  • 5.3.0

Solution

Upgrade to version 5.3.0 or above.

Impact 7.5 HIGH

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Learn more about CVSS

Weakness

  • CWE-400: Uncontrolled Resource Consumption
  • CWE-770: Allocation of Resources Without Limits or Throttling

Source file

npm/basic-ftp/GHSA-rp42-5vxx-qpwr.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:05 +0000.