Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. auth0-js
  4. ›
  5. CVE-2018-6873

CVE-2018-6873: Improper Authentication

April 4, 2018 (updated October 3, 2019)

The Auth0 authentication service allows privilege escalation because the JWT audience field is not validated.

References

  • www.securityfocus.com/bid/103695
  • auth0.com/docs/security/bulletins/cve-2018-6873
  • nvd.nist.gov/vuln/detail/CVE-2018-6873

Code Behaviors & Features

Detect and mitigate CVE-2018-6873 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions up to 8.10.1

Fixed versions

  • 8.11.0

Solution

Upgrade to version 8.11.0 or above.

Impact 9.8 CRITICAL

CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-287: Improper Authentication

Source file

npm/auth0-js/CVE-2018-6873.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:53 +0000.