Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. apostrophe
  4. ›
  5. CVE-2022-28396

CVE-2022-28396: Code Injection

April 12, 2022 (updated April 20, 2022)

Apostrophe v3.16.1 was discovered to contain a remote code execution (RCE) vulnerability via the component uploadfs.

References

  • nvd.nist.gov/vuln/detail/CVE-2022-28396
  • www.npmjs.com/package/apostrophe

Code Behaviors & Features

Detect and mitigate CVE-2022-28396 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

Version 3.16.1

Fixed versions

  • 3.17.0

Solution

Upgrade to version 3.17.0 or above.

Impact 9.8 CRITICAL

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Learn more about CVSS

Source file

npm/apostrophe/CVE-2022-28396.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:31 +0000.