Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. apostrophe
  4. ›
  5. CVE-2021-25979

CVE-2021-25979: Insufficient Session Expiration

November 8, 2021 (updated August 10, 2022)

Apostrophe CMS versions between which allows unauthenticated remote attackers to hijack recently logged-in users’ sessions.

References

  • github.com/apostrophecms/apostrophe
  • nvd.nist.gov/vuln/detail/CVE-2021-25979

Code Behaviors & Features

Detect and mitigate CVE-2021-25979 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 2.63.0 before 3.3.1

Fixed versions

  • 3.3.1

Solution

Upgrade to version 3.3.1 or above.

Impact 9.8 CRITICAL

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-613: Insufficient Session Expiration

Source file

npm/apostrophe/CVE-2021-25979.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:52 +0000.