Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. apexcharts
  4. ›
  5. CVE-2021-23327

CVE-2021-23327: Cross-site Scripting

February 9, 2021 (updated February 13, 2021)

The package apexcharts are vulnerable to Cross-site Scripting (XSS) via lack of sanitization of graph legend fields.

References

  • nvd.nist.gov/vuln/detail/CVE-2021-23327

Code Behaviors & Features

Detect and mitigate CVE-2021-23327 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 3.24.0

Fixed versions

  • 3.24.0

Solution

Upgrade to version 3.24.0 or above.

Impact 6.3 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:L

Learn more about CVSS

Weakness

  • CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Source file

npm/apexcharts/CVE-2021-23327.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:18 +0000.