Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. ansi_up
  4. ›
  5. CVE-2021-3377

CVE-2021-3377: ansi_up cross-site scripting vulnerability

March 11, 2021 (updated November 4, 2025)

The npm package ansi_up converts ANSI escape codes into HTML. In ansi_up v4, ANSI escape codes can be used to create HTML hyperlinks. Due to insufficient URL sanitization, this feature is affected by a cross-site scripting (XSS) vulnerability. This issue is fixed in v5.0.0.

References

  • doyensec.com/resources/Doyensec_Advisory_ansi_up4_XSS.pdf
  • github.com/advisories/GHSA-2v5f-23xc-v9qr
  • github.com/drudru/ansi_up/commit/c8c726ed1db979bae4f257b7fa41775155ba2e27
  • nvd.nist.gov/vuln/detail/CVE-2021-3377
  • security.netapp.com/advisory/ntap-20241108-0002

Code Behaviors & Features

Detect and mitigate CVE-2021-3377 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 5.0.0

Fixed versions

  • 5.0.0

Solution

Upgrade to version 5.0.0 or above.

Impact 6.1 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Source file

npm/ansi_up/CVE-2021-3377.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:41 +0000.