Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. angular-http-server
  4. ›
  5. GHSA-vmhw-fhj6-m3g5

GHSA-vmhw-fhj6-m3g5: Path Traversal in angular-http-server

May 31, 2019 (updated February 11, 2026)

Versions of angular-http-server before 1.4.4 are vulnerable to path traversal.

References

  • github.com/advisories/GHSA-vmhw-fhj6-m3g5
  • github.com/simonh1000/angular-http-server
  • github.com/simonh1000/angular-http-server/commit/8bafc9577161469f5dea01e0b98ea9c525d063e9
  • hackerone.com/reports/330349
  • www.npmjs.com/advisories/656

Code Behaviors & Features

Detect and mitigate GHSA-vmhw-fhj6-m3g5 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 1.4.4

Fixed versions

  • 1.4.4

Solution

Upgrade to version 1.4.4 or above.

Impact 7.5 HIGH

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Learn more about CVSS

Weakness

  • CWE-22: Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal')

Source file

npm/angular-http-server/GHSA-vmhw-fhj6-m3g5.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:36 +0000.