Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. ag-grid
  4. ›
  5. CVE-2017-16009

CVE-2017-16009: Cross-site Scripting

June 4, 2018 (updated October 9, 2019)

ag-grid is vulnerable to Cross-site Scripting (XSS) via Angular Expressions, if AngularJS is used in combination with ag-grid.

References

  • github.com/ceolter/ag-grid/issues/1287
  • nvd.nist.gov/vuln/detail/CVE-2017-16009

Code Behaviors & Features

Detect and mitigate CVE-2017-16009 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions up to 18.1.2

Fixed versions

  • 18.1.3

Solution

Upgrade to version 18.1.3 or above.

Impact 6.1 MEDIUM

CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Source file

npm/ag-grid/CVE-2017-16009.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:21 +0000.