Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. @vendure/core
  4. ›
  5. CVE-2026-40887

CVE-2026-40887: @vendure/core has a SQL Injection vulnerability

April 14, 2026 (updated April 24, 2026)

An unauthenticated SQL injection vulnerability exists in the Vendure Shop API. A user-controlled query string parameter is interpolated directly into a raw SQL expression without parameterization or validation, allowing an attacker to execute arbitrary SQL against the database. This affects all supported database backends (PostgreSQL, MySQL/MariaDB, SQLite).

The Admin API is also affected, though exploitation there requires authentication.

References

  • github.com/advisories/GHSA-9pp3-53p2-ww9v
  • github.com/vendurehq/vendure/security/advisories/GHSA-9pp3-53p2-ww9v
  • nvd.nist.gov/vuln/detail/CVE-2026-40887

Code Behaviors & Features

Detect and mitigate CVE-2026-40887 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 1.7.4 before 2.3.4, all versions starting from 3.0.0 before 3.5.7, all versions starting from 3.6.0 before 3.6.2

Fixed versions

  • 2.3.4
  • 3.5.7
  • 3.6.2

Solution

Upgrade to versions 2.3.4, 3.5.7, 3.6.2 or above.

Impact 9.1 CRITICAL

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H

Learn more about CVSS

Weakness

  • CWE-89: Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection')

Source file

npm/@vendure/core/CVE-2026-40887.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:01 +0000.