Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. @uppy/companion
  4. ›
  5. CVE-2022-0528

CVE-2022-0528: Incorrect Authorization

March 4, 2022 (updated March 11, 2022)

Exposure of Sensitive Information to an Unauthorized Actor in GitHub repository transloadit/uppy prior to 3.3.1.

References

  • github.com/advisories/GHSA-q24h-5rq3-63j9
  • github.com/transloadit/uppy/commit/267c34045a1e62c98406d8c31261c604a11e544a
  • huntr.dev/bounties/8b060cc3-2420-468e-8293-b9216620175b
  • nvd.nist.gov/vuln/detail/CVE-2022-0528

Code Behaviors & Features

Detect and mitigate CVE-2022-0528 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 3.3.1

Fixed versions

  • 3.3.1

Solution

Upgrade to version 3.3.1 or above.

Impact 7.5 HIGH

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Learn more about CVSS

Weakness

  • CWE-863: Incorrect Authorization

Source file

npm/@uppy/companion/CVE-2022-0528.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:22 +0000.