Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. @uppy/companion
  4. ›
  5. CVE-2022-0086

CVE-2022-0086: uppy's companion module is vulnerable to Server-Side Request Forgery (SSRF)

January 6, 2022 (updated December 22, 2025)

uppy’s companion module is vulnerable to Server-Side Request Forgery (SSRF) via IPv4-mapped IPv6 addresses.

References

  • github.com/advisories/GHSA-x8rq-rc7x-5fg5
  • github.com/transloadit/uppy
  • github.com/transloadit/uppy/commit/fc137e30a2a3102eb191141f280d5de20dacdf8f
  • github.com/transloadit/uppy/pull/3403
  • github.com/transloadit/uppy/releases/tag/uppy%402.3.3
  • huntr.dev/bounties/c1c03ef6-3f18-4976-a9ad-08c251279122
  • nvd.nist.gov/vuln/detail/CVE-2022-0086

Code Behaviors & Features

Detect and mitigate CVE-2022-0086 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 3.1.5

Fixed versions

  • 3.1.5

Solution

Upgrade to version 3.1.5 or above.

Impact 9.8 CRITICAL

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-918: Server-Side Request Forgery (SSRF)

Source file

npm/@uppy/companion/CVE-2022-0086.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:51 +0000.