Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. @strapi/core
  4. ›
  5. CVE-2025-53092

CVE-2025-53092: Strapi core vulnerable to sensitive data exposure via CORS misconfiguration

October 16, 2025 (updated January 29, 2026)

A CORS misconfiguration vulnerability exists in default installations of Strapi where attacker-controlled origins are improperly reflected in API responses.

References

  • github.com/advisories/GHSA-9329-mxxw-qwf8
  • github.com/strapi/strapi
  • github.com/strapi/strapi/commit/6e535cb756
  • github.com/strapi/strapi/releases/tag/v5.20.0
  • github.com/strapi/strapi/security/advisories/GHSA-9329-mxxw-qwf8
  • nvd.nist.gov/vuln/detail/CVE-2025-53092

Code Behaviors & Features

Detect and mitigate CVE-2025-53092 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 5.20.0

Fixed versions

  • 5.20.0

Solution

Upgrade to version 5.20.0 or above.

Impact 6.5 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N

Learn more about CVSS

Weakness

  • CWE-200: Exposure of Sensitive Information to an Unauthorized Actor
  • CWE-284: Improper Access Control
  • CWE-364: Signal Handler Race Condition
  • CWE-942: Permissive Cross-domain Policy with Untrusted Domains

Source file

npm/@strapi/core/CVE-2025-53092.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:34 +0000.