CVE-2026-22599: Strapi Vulnerable to SQL Injection in Content Type Builder
(updated )
- CVE: CVE-2026-22599
- CVSS v3.1 Vector:
CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:N/SC:H/SI:H/SA:N(9.3 — Critical) - Affected Versions:
@strapi/content-type-builder<=5.33.1 (v5),@strapi/plugin-content-type-builder<=4.26.0 (v4) - How to Patch: Immediately update your Strapi to >=5.33.2 (v5) or >=4.26.1 (v4)
References
Code Behaviors & Features
Detect and mitigate CVE-2026-22599 with GitLab Dependency Scanning
Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →