Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. @ronomon/opened
  4. ›
  5. CVE-2021-29300

CVE-2021-29300: Command Injection

May 24, 2021 (updated June 28, 2022)

The @ronomon/opened library is vulnerable to a command injection vulnerability which would allow a remote attacker to execute commands on the system if the library was used with untrusted input.

References

  • nvd.nist.gov/vuln/detail/CVE-2021-29300

Code Behaviors & Features

Detect and mitigate CVE-2021-29300 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 1.5.2

Fixed versions

  • 1.5.2

Solution

Upgrade to version 1.5.2 or above.

Impact 9.8 CRITICAL

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-78: Improper Neutralization of Special Elements used in an OS Command ('OS Command Injection')

Source file

npm/@ronomon/opened/CVE-2021-29300.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:43 +0000.