Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. @quasar/quasar-ui-qmarkdown
  4. ›
  5. CVE-2025-43954

CVE-2025-43954: QMarkdown Cross-Site Scripting (XSS) vulnerability

April 20, 2025 (updated April 21, 2025)

QMarkdown (aka quasar-ui-qmarkdown) before 2.0.5 allows XSS via headers even when when no-html is set.

References

  • github.com/advisories/GHSA-wm65-ph3w-587c
  • github.com/quasarframework/quasar-ui-qmarkdown
  • github.com/quasarframework/quasar-ui-qmarkdown/commit/b61dff84851c45369cf931db5bd93db177c657f6
  • github.com/quasarframework/quasar-ui-qmarkdown/compare/v2.0.4...v2.0.5
  • nvd.nist.gov/vuln/detail/CVE-2025-43954

Code Behaviors & Features

Detect and mitigate CVE-2025-43954 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 2.0.5

Fixed versions

  • 2.0.5

Solution

Upgrade to version 2.0.5 or above.

Impact 4.9 MEDIUM

CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:L/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Source file

npm/@quasar/quasar-ui-qmarkdown/CVE-2025-43954.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:05 +0000.