Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. @opentelemetry/sdk-node
  4. ›
  5. CVE-2026-44902

CVE-2026-44902: Prometheus exporter process crash via malformed HTTP request

May 11, 2026 (updated October 19, 2026)

A single malformed HTTP request crashes any Node.js process running the OpenTelemetry JS Prometheus exporter. The metrics endpoint (default 0.0.0.0:9464) has no error handling around URL parsing, so a request with an invalid URI causes an uncaught TypeError that terminates the process.

You are affected by this vulnerability if either of the following apply to your application:

  • you directly use @opentelemetry/exporter-prometheus in your code through its built-in server.
  • your OTEL_METRICS_EXPORTER environment variable includes prometheus AND
  • you use @opentelemetry/sdk-node
  • you use @opentelemetry/auto-instrumentations-node via --require @opentelemetry/auto-instrumentations-node/register/--import @opentelemetry/auto-instrumentations-node/register

References

  • github.com/advisories/GHSA-q7rr-3cgh-j5r3
  • github.com/github/advisory-database/pull/10226
  • github.com/open-telemetry/opentelemetry-js-contrib/blob/3ef5205e5353010184c69ff7b9f0f4830f0932de/metapackages/auto-instrumentations-node/package.json
  • github.com/open-telemetry/opentelemetry-js/blob/616d27a0a111c9b813d14c56d8d8f1ffbd7d7156/experimental/packages/opentelemetry-sdk-node/package.json
  • github.com/open-telemetry/opentelemetry-js/security/advisories/GHSA-q7rr-3cgh-j5r3
  • nvd.nist.gov/vuln/detail/CVE-2026-44902

Code Behaviors & Features

Detect and mitigate CVE-2026-44902 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 0.57.0 before 0.217.0

Fixed versions

  • 0.217.0

Solution

Upgrade to version 0.217.0 or above.

Impact 7.5 HIGH

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Learn more about CVSS

Weakness

  • CWE-755: Improper Handling of Exceptional Conditions

Source file

npm/@opentelemetry/sdk-node/CVE-2026-44902.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:20 +0000.