Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. @nuxt/devtools
  4. ›
  5. CVE-2025-52662

CVE-2025-52662: Nuxt DevTools vulnerable to cross-site scripting (XSS)

November 7, 2025

A vulnerability in Nuxt DevTools has been fixed in version 2.6.4*. This issue may have allowed Nuxt auth token extraction via XSS under certain configurations. All users are encouraged to upgrade.

References

  • github.com/advisories/GHSA-xmq3-q5pm-rp26
  • github.com/nuxt/devtools
  • github.com/nuxt/devtools/commit/7cadbbe9
  • github.com/nuxt/devtools/releases/tag/v2.6.4
  • nvd.nist.gov/vuln/detail/CVE-2025-52662
  • vercel.com/changelog/cve-2025-52662-xss-on-nuxt-devtools

Code Behaviors & Features

Detect and mitigate CVE-2025-52662 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 2.6.4

Fixed versions

  • 2.6.4

Solution

Upgrade to version 2.6.4 or above.

Impact 6.9 MEDIUM

CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:L/I:H/A:N

Learn more about CVSS

Weakness

  • CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Source file

npm/@nuxt/devtools/CVE-2025-52662.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:17:17 +0000.