Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. @node-oauth/oauth2-server
  4. ›
  5. CVE-2026-41213

CVE-2026-41213: @node-oauth/oauth2-server: PKCE code_verifier ABNF not enforced in token exchange allows brute-force redemption of intercepted authorization codes

April 16, 2026 (updated April 24, 2026)

The token exchange path accepts RFC7636-invalid code_verifier values (including one-character strings) for S256 PKCE flows. Because short/weak verifiers are accepted and failed verifier attempts do not consume the authorization code, an attacker who intercepts an authorization code can brute-force code_verifier guesses online until token issuance succeeds.

References

  • github.com/advisories/GHSA-jhm7-29pj-4xvf
  • github.com/node-oauth/node-oauth2-server/security/advisories/GHSA-jhm7-29pj-4xvf
  • nvd.nist.gov/vuln/detail/CVE-2026-41213

Code Behaviors & Features

Detect and mitigate CVE-2026-41213 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 5.3.0

Fixed versions

  • 5.3.0

Solution

Upgrade to version 5.3.0 or above.

Impact 5.9 MEDIUM

CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N

Learn more about CVSS

Weakness

  • CWE-1289: Improper Validation of Unsafe Equivalence in Input
  • CWE-307: Improper Restriction of Excessive Authentication Attempts

Source file

npm/@node-oauth/oauth2-server/CVE-2026-41213.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:41 +0000.