Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. @nextcloud/dialogs
  4. ›
  5. CVE-2021-29438

CVE-2021-29438: Cross-site Scripting

April 13, 2021 (updated November 7, 2023)

The Nextcloud dialogs library insufficiently escaped text input passed to a toast. If your application displays toasts with user-supplied input, this could lead to a XSS vulnerability. The vulnerability has been patched If you need to display HTML in the toast, explicitly pass the options.isHTML config flag.

References

  • nvd.nist.gov/vuln/detail/CVE-2021-29438

Code Behaviors & Features

Detect and mitigate CVE-2021-29438 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 3.1.2

Fixed versions

  • 3.1.2

Solution

Upgrade to version 3.1.2 or above.

Impact 5.4 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Source file

npm/@nextcloud/dialogs/CVE-2021-29438.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:01 +0000.