Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. @lobehub/chat
  4. ›
  5. CVE-2024-32965

CVE-2024-32965: @lobehub/chat Server Side Request Forgery vulnerability

November 26, 2024

lobe-chat before 1.19.13 has an unauthorized ssrf vulnerability. An attacker can construct malicious requests to cause SSRF without logging in, attack intranet services, and leak sensitive information.

References

  • github.com/advisories/GHSA-2xcc-vm3f-m8rw
  • github.com/lobehub/lobe-chat
  • github.com/lobehub/lobe-chat/commit/e960a23b0c69a5762eb27d776d33dac443058faf
  • github.com/lobehub/lobe-chat/security/advisories/GHSA-2xcc-vm3f-m8rw
  • nvd.nist.gov/vuln/detail/CVE-2024-32965

Code Behaviors & Features

Detect and mitigate CVE-2024-32965 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 1.19.13

Fixed versions

  • 1.19.13

Solution

Upgrade to version 1.19.13 or above.

Impact 8.1 HIGH

CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:L/A:L

Learn more about CVSS

Weakness

  • CWE-918: Server-Side Request Forgery (SSRF)

Source file

npm/@lobehub/chat/CVE-2024-32965.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:44 +0000.