Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. @lobehub/chat
  4. ›
  5. CVE-2024-24566

CVE-2024-24566: Improper Access Control

January 31, 2024

Lobe Chat is a chatbot framework that supports speech synthesis, multimodal, and extensible Function Call plugin system. When the application is password-protected (deployed with the ACCESS_CODE option), it is possible to access plugins without proper authorization (without password). This vulnerability is patched in 0.122.4.

References

  • github.com/advisories/GHSA-pf55-fj96-xf37
  • github.com/lobehub/lobe-chat/commit/2184167f09ab68e4efa051ee984ea0c4e7c48fbd
  • github.com/lobehub/lobe-chat/security/advisories/GHSA-pf55-fj96-xf37
  • nvd.nist.gov/vuln/detail/CVE-2024-24566

Code Behaviors & Features

Detect and mitigate CVE-2024-24566 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions up to 0.122.3

Fixed versions

  • 0.122.4

Solution

Upgrade to version 0.122.4 or above.

Impact 5.3 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-284: Improper Access Control

Source file

npm/@lobehub/chat/CVE-2024-24566.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:42 +0000.