Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. @leanprover/unicode-input-component
  4. ›
  5. CVE-2026-32732

CVE-2026-32732: XSS in @leanprover/unicode-input-component

March 16, 2026

Projects that use @leanprover/unicode-input-component are vulnerable to an XSS exploit in 0.1.9 of the package and lower. The component re-inserted text in the input element back into the input element as unescaped HTML.

References

  • github.com/advisories/GHSA-6ggm-pwr9-r5h2
  • github.com/leanprover/vscode-lean4
  • github.com/leanprover/vscode-lean4/pull/735
  • github.com/leanprover/vscode-lean4/security/advisories/GHSA-6ggm-pwr9-r5h2
  • leanprover.zulipchat.com/
  • nvd.nist.gov/vuln/detail/CVE-2026-32732

Code Behaviors & Features

Detect and mitigate CVE-2026-32732 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 0.2.0

Fixed versions

  • 0.2.0

Solution

Upgrade to version 0.2.0 or above.

Impact

CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:N

Learn more about CVSS

Weakness

  • CWE-80: Improper Neutralization of Script-Related HTML Tags in a Web Page (Basic XSS)

Source file

npm/@leanprover/unicode-input-component/CVE-2026-32732.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:02 +0000.