Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. @hulumi/baseline
  4. ›
  5. GHSA-gfp8-mp24-5vxg

GHSA-gfp8-mp24-5vxg: @hulumi/baseline: CloudTrail selector tampering events were not fully detected

May 21, 2026

Impact: @hulumi/baseline versions before 1.3.2 could miss some CloudTrail event-selector tampering evidence, reducing coverage for changes to audit logging configuration.

Patched in 1.3.2: detection coverage and regression tests were expanded.

Remediation: upgrade @hulumi/baseline to 1.3.2 or later and rerun affected previews/checks.

References

  • github.com/advisories/GHSA-gfp8-mp24-5vxg
  • github.com/kerberosmansour/hulumi/security/advisories/GHSA-gfp8-mp24-5vxg

Code Behaviors & Features

Detect and mitigate GHSA-gfp8-mp24-5vxg with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 1.3.2

Fixed versions

  • 1.3.2

Solution

Upgrade to version 1.3.2 or above.

Impact 5.3 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-778: Insufficient Logging

Source file

npm/@hulumi/baseline/GHSA-gfp8-mp24-5vxg.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:54 +0000.