Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. @hapi/hapi
  4. ›
  5. GMS-2020-27

GMS-2020-27: Denial of Service in @hapi/hapi

September 3, 2020

Versions of @hapi/hapi are vulnerable to Denial of Service. The CORS request handler has a vulnerability which will cause the function to throw a system error if the header contains some invalid values. If no unhandled exception handler is available, the application will exist, allowing an attacker to shut down services.

References

  • github.com/advisories/GHSA-23vw-mhv5-grv5
  • www.npmjs.com/advisories/1482

Code Behaviors & Features

Detect and mitigate GMS-2020-27 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 18.4.1, all versions starting from 19.0.0 before 19.1.1

Fixed versions

  • 18.4.1
  • 19.1.1

Solution

Upgrade to versions 18.4.1, 19.1.1 or above.

Source file

npm/@hapi/hapi/GMS-2020-27.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:16 +0000.