Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. @fonoster/voice
  4. ›
  5. CVE-2024-43035

CVE-2024-43035: Fonoster is vulnerable to directory traversal

March 5, 2026 (updated March 6, 2026)

Fonoster 0.5.5 before 0.6.1 allows ../ directory traversal to read arbitrary files via the /sounds/:file or /tts/:file VoiceServer endpoint. This occurs in serveFiles in mods/voice/src/utils.ts. NOTE: serveFiles exists in 0.5.5 but not in the next release, 0.6.1.

References

  • github.com/advisories/GHSA-9fv2-c7v6-p45w
  • github.com/fonoster/fonoster
  • github.com/fonoster/fonoster/blob/4a1438d9dedeaf7b2a5b6a50d5e233f994e2b2cf/mods/voice/src/utils.ts
  • nvd.nist.gov/vuln/detail/CVE-2024-43035
  • zeropath.com/blog/fonoster-voiceserver-lfi-vulnerability

Code Behaviors & Features

Detect and mitigate CVE-2024-43035 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 0.5.5 before 0.6.1

Fixed versions

  • 0.6.1

Solution

Upgrade to version 0.6.1 or above.

Impact 5.8 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:N/A:N

Learn more about CVSS

Weakness

  • CWE-24: Path Traversal: '../filedir'

Source file

npm/@fonoster/voice/CVE-2024-43035.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:17:25 +0000.