Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. @fastify/middie
  4. ›
  5. CVE-2026-33804

CVE-2026-33804: @fastify/middie vulnerable to middleware bypass via deprecated ignoreDuplicateSlashes option

April 16, 2026

@fastify/middie v9.3.1 and earlier does not read the deprecated (but still functional) top-level ignoreDuplicateSlashes option, only reading from routerOptions. This creates a normalization gap: Fastify’s router normalizes duplicate slashes but middie does not, allowing middleware bypass via URLs with duplicate leading slashes (e.g., //admin/secret).

This only affects applications using the deprecated top-level configuration style (fastify({ ignoreDuplicateSlashes: true })). Applications using routerOptions: { ignoreDuplicateSlashes: true } are not affected.

This is distinct from GHSA-8p85-9qpw-fwgw (CVE-2026-2880), which was patched in v9.2.0.

References

  • cna.openjsf.org/security-advisories.html
  • github.com/advisories/GHSA-v9ww-2j6r-98q6
  • github.com/fastify/middie/security/advisories/GHSA-v9ww-2j6r-98q6
  • nvd.nist.gov/vuln/detail/CVE-2026-33804

Code Behaviors & Features

Detect and mitigate CVE-2026-33804 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 9.3.2

Fixed versions

  • 9.3.2

Solution

Upgrade to version 9.3.2 or above.

Impact 7.4 HIGH

CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N

Learn more about CVSS

Weakness

  • CWE-436: Interpretation Conflict

Source file

npm/@fastify/middie/CVE-2026-33804.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:54 +0000.