Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. @eslint/plugin-kit
  4. ›
  5. GHSA-xffm-g5w8-qvg7

GHSA-xffm-g5w8-qvg7: @eslint/plugin-kit is vulnerable to Regular Expression Denial of Service attacks through ConfigCommentParser

July 18, 2025 (updated November 10, 2025)

The ConfigCommentParser#parseJSONLikeConfig API is vulnerable to a Regular Expression Denial of Service (ReDoS) attack in its only argument.

References

  • github.com/advisories/GHSA-xffm-g5w8-qvg7
  • github.com/eslint/rewrite
  • github.com/eslint/rewrite/commit/b283f64099ad6c6b5043387c091691d21b387805
  • github.com/eslint/rewrite/security/advisories/GHSA-xffm-g5w8-qvg7

Code Behaviors & Features

Detect and mitigate GHSA-xffm-g5w8-qvg7 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 0.3.4

Fixed versions

  • 0.3.4

Solution

Upgrade to version 0.3.4 or above.

Impact 4.3 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L

Learn more about CVSS

Weakness

  • CWE-1333: Inefficient Regular Expression Complexity

Source file

npm/@eslint/plugin-kit/GHSA-xffm-g5w8-qvg7.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:20 +0000.