Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. @directus/api
  4. ›
  5. CVE-2025-64749

CVE-2025-64749: Directus Vulnerable to Information Leakage in Existing Collections

November 13, 2025 (updated November 15, 2025)

An observable difference in error messaging was found in the Directus REST API. The /items/{collection} API returns different error messages for these two cases:

  1. A user tries to access an existing collection which they are not authorized to access.
  2. A user tries to access a non-existing collection.

The two differing error messages leak the existence of collections to users which are not authorized to access these collections.

References

  • github.com/advisories/GHSA-cph6-524f-3hgr
  • github.com/directus/directus
  • github.com/directus/directus/commit/f99c9b89071f9d136cc9b0d0c182f2d24542bc31
  • github.com/directus/directus/security/advisories/GHSA-cph6-524f-3hgr
  • nvd.nist.gov/vuln/detail/CVE-2025-64749

Code Behaviors & Features

Detect and mitigate CVE-2025-64749 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 32.0.0

Fixed versions

  • 32.0.0

Solution

Upgrade to version 32.0.0 or above.

Impact 4.3 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N

Learn more about CVSS

Weakness

  • CWE-203: Observable Discrepancy
  • CWE-209: Generation of Error Message Containing Sensitive Information

Source file

npm/@directus/api/CVE-2025-64749.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:17:23 +0000.