Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. @cubejs-backend/server-core
  4. ›
  5. CVE-2026-25958

CVE-2026-25958: Cube Core is vulnerable to privilege escalation via a specially crafted request

February 10, 2026

Impact

It is possible to make a specially crafted request with a valid API token that leads to privilege escalation.

Affected Versions:

≥= 0.27.19

Mitigation:

Upgrade to a patched version:

  • 1.5.13 and later (regular release)
  • 1.4.2 (active LTS release)
  • 1.0.14 (end-of-life LTS release)

References

The issue was reported by our Core engineer, Dmitrii Patsura (@ovr), in our internal Slack and was promptly patched in a recent update.

References

  • github.com/advisories/GHSA-v226-32c7-x2v7
  • github.com/cube-js/cube
  • github.com/cube-js/cube/security/advisories/GHSA-v226-32c7-x2v7
  • nvd.nist.gov/vuln/detail/CVE-2026-25958

Code Behaviors & Features

Detect and mitigate CVE-2026-25958 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 0.27.19 before 1.0.14, all versions starting from 1.1.0 before 1.4.2, all versions starting from 1.5.0 before 1.5.13

Fixed versions

  • 1.0.14
  • 1.4.2
  • 1.5.13

Solution

Upgrade to versions 1.0.14, 1.4.2, 1.5.13 or above.

Impact 7.7 HIGH

CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N

Learn more about CVSS

Weakness

  • CWE-807: Reliance on Untrusted Inputs in a Security Decision

Source file

npm/@cubejs-backend/server-core/CVE-2026-25958.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:48 +0000.