Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. @cubejs-backend/server-core
  4. ›
  5. CVE-2026-25957

CVE-2026-25957: Cube Core is vulnerable to Denial of Service (DoS) via crafted request

February 10, 2026

Impact

It is possible to make the entire Cube API unavailable by submitting a specially crafted request to a Cube API endpoint.

Affected Versions:

>= 1.1.17

Mitigation:

Upgrade to a patched version:

  • 1.5.13 and later (regular release)
  • 1.4.2 (active LTS release)

References

The issue was reported by our Core engineer, Dmitrii Patsura (@ovr), in our internal Slack and was promptly patched in a recent update.

References

  • github.com/advisories/GHSA-9vph-2hvm-x66g
  • github.com/cube-js/cube
  • github.com/cube-js/cube/security/advisories/GHSA-9vph-2hvm-x66g
  • nvd.nist.gov/vuln/detail/CVE-2026-25957

Code Behaviors & Features

Detect and mitigate CVE-2026-25957 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 1.1.17 before 1.4.2, all versions starting from 1.5.0 before 1.5.13

Fixed versions

  • 1.4.2
  • 1.5.13

Solution

Upgrade to versions 1.4.2, 1.5.13 or above.

Impact 6.5 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H

Learn more about CVSS

Weakness

  • CWE-755: Improper Handling of Exceptional Conditions

Source file

npm/@cubejs-backend/server-core/CVE-2026-25957.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:17:19 +0000.