Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. @ckeditor/ckeditor5-clipboard
  4. ›
  5. CVE-2025-58064

CVE-2025-58064: CKEditor 5 cross-site scripting (XSS) vulnerability in the clipboard package

September 3, 2025 (updated November 10, 2025)

A Cross-Site Scripting (XSS) vulnerability has been discovered in the CKEditor 5 clipboard package. This vulnerability could be triggered by a specific user action, leading to unauthorized JavaScript code execution, if the attacker managed to insert a malicious content into the editor, which might happen with a very specific editor configuration.

References

  • github.com/advisories/GHSA-x9gp-vjh6-3wv6
  • github.com/ckeditor/ckeditor5
  • github.com/ckeditor/ckeditor5/commit/b210e90c6cf84e662ef6c7daf93a92355a961bf2
  • github.com/ckeditor/ckeditor5/security/advisories/GHSA-x9gp-vjh6-3wv6
  • nvd.nist.gov/vuln/detail/CVE-2025-58064

Code Behaviors & Features

Detect and mitigate CVE-2025-58064 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 44.2.0 before 45.2.2, all versions starting from 46.0.0 before 46.0.3

Fixed versions

  • 45.2.2
  • 46.0.3

Solution

Upgrade to versions 45.2.2, 46.0.3 or above.

Impact 4.3 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Source file

npm/@ckeditor/ckeditor5-clipboard/CVE-2025-58064.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:51 +0000.