Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. @cap-js/openapi
  4. ›
  5. GHSA-jpvj-wpmj-h7rv

GHSA-jpvj-wpmj-h7rv: Supply chain compromise via malicious @cap-js/openapi

June 4, 2026

On May 19, 2026, a compromised version of @cap-js/openapi@1.4.1 was published. The malicious packages harvested credentials and attempted self-propagation. If a compromised version was installed, all credentials accessible on that machine (npm tokens, cloud provider credentials, SSH keys, GitHub PATs) should be considered compromised.

References

  • github.com/advisories/GHSA-jpvj-wpmj-h7rv
  • github.com/cap-js/openapi/security/advisories/GHSA-jpvj-wpmj-h7rv
  • me.sap.com/notes/3747787
  • www.sap.com/documents/2026/05/8203a8b9-4d7f-0010-bca6-c68f7e60039b.html

Code Behaviors & Features

Detect and mitigate GHSA-jpvj-wpmj-h7rv with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 1.4.1 before 1.4.2

Fixed versions

  • 1.4.2

Solution

Upgrade to version 1.4.2 or above.

Impact 9.6 CRITICAL

CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-506: Embedded Malicious Code

Source file

npm/@cap-js/openapi/GHSA-jpvj-wpmj-h7rv.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:17:17 +0000.