Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. @builder.io/qwik
  4. ›
  5. CVE-2026-27971

CVE-2026-27971: Qwik vulnerable to Unauthenticated RCE via server$ Deserialization

March 2, 2026 (updated March 4, 2026)

qwik <=1.19.0 is vulnerable to RCE due to an unsafe deserialization vulnerability in the server$ RPC mechanism that allows any unauthenticated user to execute arbitrary code on the server with a single HTTP request. Affects any deployment where require() is available at runtime.

References

  • github.com/QwikDev/qwik
  • github.com/QwikDev/qwik/releases/tag/%40builder.io%2Fqwik%401.19.1
  • github.com/QwikDev/qwik/security/advisories/GHSA-p9x5-jp3h-96mm
  • github.com/advisories/GHSA-p9x5-jp3h-96mm
  • nvd.nist.gov/vuln/detail/CVE-2026-27971

Code Behaviors & Features

Detect and mitigate CVE-2026-27971 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 1.19.1

Fixed versions

  • 1.19.1

Solution

Upgrade to version 1.19.1 or above.

Impact 9.8 CRITICAL

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-502: Deserialization of Untrusted Data

Source file

npm/@builder.io/qwik/CVE-2026-27971.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:17:01 +0000.