Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. @auth0/nextjs-auth0
  4. ›
  5. CVE-2025-46344

CVE-2025-46344: Auth0 NextJS SDK v4 Missing Session Invalidation

April 29, 2025 (updated October 31, 2025)

Overview

Auth0 NextJS v4.0.1 to v4.5.0 does not invoke .setExpirationTime when generating a JWE token for the session. As a result, the JWE does not contain an internal expiration claim. While the session cookie may expire or be cleared, the JWE remains valid.

Am I Affected?

You are affected if you are using Auth0 NextJS SDK v4.

Fix

Upgrade to v4.5.1.

References

  • github.com/advisories/GHSA-pjr6-jx7r-j4r6
  • github.com/auth0/nextjs-auth0
  • github.com/auth0/nextjs-auth0/commit/a4f061aed02ffa132feca8adfbd11704df17e1c3
  • github.com/auth0/nextjs-auth0/releases/tag/v4.5.1
  • github.com/auth0/nextjs-auth0/security/advisories/GHSA-pjr6-jx7r-j4r6
  • nvd.nist.gov/vuln/detail/CVE-2025-46344

Code Behaviors & Features

Detect and mitigate CVE-2025-46344 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 4.0.1 before 4.5.1

Fixed versions

  • 4.5.1

Solution

Upgrade to version 4.5.1 or above.

Impact 6.5 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N

Learn more about CVSS

Weakness

  • CWE-613: Insufficient Session Expiration

Source file

npm/@auth0/nextjs-auth0/CVE-2025-46344.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:46 +0000.