Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. @auth0/nextjs-auth0
  4. ›
  5. CVE-2021-32702

CVE-2021-32702: Cross-site Scripting

June 25, 2021 (updated November 7, 2023)

nextjs-auth0 lacks HTML escaping for error messages.

References

  • nvd.nist.gov/vuln/detail/CVE-2021-32702

Code Behaviors & Features

Detect and mitigate CVE-2021-32702 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 1.4.2

Fixed versions

  • 1.4.2

Solution

Upgrade to version 1.4.2 or above.

Impact 6.1 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Source file

npm/@auth0/nextjs-auth0/CVE-2021-32702.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:49 +0000.