Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. @apollo/composition
  4. ›
  5. GHSA-m8jr-fxqx-8xx6

GHSA-m8jr-fxqx-8xx6: Apollo Federation has Improper Enforcement of Access Control on Transitive Fields

November 14, 2025

A vulnerability in Apollo Federation’s composition logic did not enforce that fields depending on protected data through @requires and/or @fromContext directives have the same access control requirements as the fields they reference. This allowed queries to access protected fields indirectly through their dependencies, bypassing access control checks. A fix to composition logic in Federation now enforces that dependent fields match the access control requirements from of the fields they reference.

References

  • github.com/advisories/GHSA-m8jr-fxqx-8xx6
  • github.com/apollographql/federation
  • github.com/apollographql/federation/commit/09e596e6a0c753071ca822e84f525d73ada395cf
  • github.com/apollographql/federation/commit/0d8fca1c8cc375bb8486f11f339984b69267417d
  • github.com/apollographql/federation/commit/20c75d1d60a48fc289d88c8d29652f1afc7553e4
  • github.com/apollographql/federation/commit/e1c58611c3c996b4fff98a54e49f00549ff2115d
  • github.com/apollographql/federation/security/advisories/GHSA-m8jr-fxqx-8xx6

Code Behaviors & Features

Detect and mitigate GHSA-m8jr-fxqx-8xx6 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 2.9.5, all versions starting from 2.10.0-alpha.3 before 2.10.4, all versions starting from 2.11.0-preview.1 before 2.11.5, all versions starting from 2.12.0-preview.0 before 2.12.1

Fixed versions

  • 2.9.5
  • 2.10.4
  • 2.11.5
  • 2.12.1

Solution

Upgrade to versions 2.10.4, 2.11.5, 2.12.1, 2.9.5 or above.

Impact 7.5 HIGH

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Learn more about CVSS

Weakness

  • CWE-863: Incorrect Authorization

Source file

npm/@apollo/composition/GHSA-m8jr-fxqx-8xx6.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:24 +0000.