Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. @angular/service-worker
  4. ›
  5. CVE-2026-50169

CVE-2026-50169: Angular Service Worker Policy-Bypass & Credential-Stripping Vulnerabilities

June 15, 2026 (updated July 15, 2026)

An issue in the @angular/service-worker package compromises the integrity of request-policy enforcement during request reconstruction. When the Angular Service Worker intercepts network requests for matched assets, it reconstructs a new Request object using an internal helper function.

During this reconstruction process, the helper function strips the strict, client-defined request redirect policy configuration (such as redirect: 'error'), falling back to the browser’s default 'follow' strategy.

If the target web application makes client-side requests with a strict policy (e.g., expecting a network error instead of automatically following redirects), the service worker will bypass this instruction and automatically follow HTTP 3xx redirects to other destinations. This acts as an unintended proxy/intermediary (“Confused Deputy”) and can result in cookie/credential exposure or same-origin session-restricted data leakage if public dynamic routes redirect to sensitive routes.

References

  • github.com/advisories/GHSA-gv2q-mqqv-365m
  • github.com/angular/angular/pull/67494
  • github.com/angular/angular/security/advisories/GHSA-gv2q-mqqv-365m
  • nvd.nist.gov/vuln/detail/CVE-2026-50169

Code Behaviors & Features

Detect and mitigate CVE-2026-50169 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions up to 18.2.14, all versions starting from 19.0.0-next.0 before 19.2.23, all versions starting from 20.0.0-next.0 before 20.3.22, all versions starting from 21.0.0-next.0 before 21.2.15, all versions starting from 22.0.0-next.0 before 22.0.0-rc.2

Fixed versions

  • 19.2.23
  • 20.3.22
  • 21.2.15
  • 22.0.0-rc.2

Solution

Upgrade to versions 19.2.23, 20.3.22, 21.2.15, 22.0.0-rc.2 or above.

Impact 6.1 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-200: Exposure of Sensitive Information to an Unauthorized Actor
  • CWE-441: Unintended Proxy or Intermediary ('Confused Deputy')
  • CWE-524: Use of Cache Containing Sensitive Information

Source file

npm/@angular/service-worker/CVE-2026-50169.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:43 +0000.