Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. @adobe/css-tools
  4. ›
  5. CVE-2023-48631

CVE-2023-48631: @adobe/css-tools Improper Input Validation and Inefficient Regular Expression Complexity

December 14, 2023 (updated December 18, 2023)

Impact

@adobe/css-tools version 4.3.1 and earlier are affected by an Improper Input Validation vulnerability that could result in a denial of service while attempting to parse CSS.

Patches

The issue has been resolved in 4.3.2.

Workarounds

None

References

N/A

References

  • github.com/adobe/css-tools/commit/472bef91bde9caab305f3f36231ad0c253581b43
  • github.com/adobe/css-tools/issues/211
  • github.com/adobe/css-tools/pull/249
  • github.com/adobe/css-tools/security/advisories/GHSA-prr3-c3m5-p7q2
  • github.com/advisories/GHSA-prr3-c3m5-p7q2

Code Behaviors & Features

Detect and mitigate CVE-2023-48631 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 4.3.2

Fixed versions

  • 4.3.2

Solution

Upgrade to version 4.3.2 or above.

Impact 7.5 HIGH

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Learn more about CVSS

Weakness

  • CWE-1333: Inefficient Regular Expression Complexity

Source file

npm/@adobe/css-tools/CVE-2023-48631.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:33 +0000.