Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. @acrontum/filesystem-template
  4. ›
  5. CVE-2022-21186

CVE-2022-21186: Improper Neutralization of Special Elements used in a Command ('Command Injection')

August 5, 2022 (updated August 8, 2023)

The package @acrontum/filesystem-template before 0.0.2 is vulnerable to Arbitrary Command Injection due to the fetchRepo API missing sanitization of the href field of external input.

References

  • github.com/acrontum/filesystem-template/pull/14/commits/baeb727b60991ad82d9e63ac660883793abc0acc
  • nvd.nist.gov/vuln/detail/CVE-2022-21186
  • security.snyk.io/vuln/SNYK-JS-ACRONTUMFILESYSTEMTEMPLATE-2419071

Code Behaviors & Features

Detect and mitigate CVE-2022-21186 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 0.0.2

Fixed versions

  • 0.0.2

Solution

Upgrade to version 0.0.2 or above.

Impact 9.8 CRITICAL

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Learn more about CVSS

Source file

npm/@acrontum/filesystem-template/CVE-2022-21186.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:59 +0000.