Advisory Database
  • Advisories
  • Dependency Scanning
  1. maven
  2. ›
  3. struts/struts
  4. ›
  5. CVE-2006-1546

CVE-2006-1546: Apache Struts vulnerable to Improper Input Validation

May 1, 2022 (updated June 7, 2022)

Apache Software Foundation (ASF) Struts before 1.2.9 allows remote attackers to bypass validation via a request with a ‘org.apache.struts.taglib.html.Constants.CANCEL’ parameter, which causes the action to be canceled but would not be detected from applications that do not use the isCancelled check.

References

  • mail-archives.apache.org/mod_mbox/struts-dev/200601.mbox/%3cdr169r$623$2@sea.gmane.org%3e
  • mail-archives.apache.org/mod_mbox/struts-user/200601.mbox/%3c20060121221800.15814.qmail@web32607.mail.mud.yahoo.com%3e
  • exchange.xforce.ibmcloud.com/vulnerabilities/25612
  • github.com/advisories/GHSA-vf8g-mpmw-qv87
  • nvd.nist.gov/vuln/detail/CVE-2006-1546

Code Behaviors & Features

Detect and mitigate CVE-2006-1546 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 1.2.9

Fixed versions

  • 1.2.9

Solution

Upgrade to version 1.2.9 or above.

Impact 7.5 HIGH

AV:N/AC:L/Au:N/C:P/I:P/A:P

Learn more about CVSS

Source file

maven/struts/struts/CVE-2006-1546.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:51 +0000.