Advisory Database
  • Advisories
  • Dependency Scanning
  1. maven
  2. ›
  3. ru.yandex.jenkins.plugins.debuilder/debian-package-builder
  4. ›
  5. CVE-2020-2125

CVE-2020-2125: Insufficiently Protected Credentials

February 12, 2020 (updated February 13, 2020)

Jenkins Debian Package Builder Plugin stores a GPG passphrase unencrypted in its global configuration file on the Jenkins master where it can be viewed by users with access to the master file system.

References

  • jenkins.io/security/advisory/2020-02-12/
  • nvd.nist.gov/vuln/detail/CVE-2020-2125

Code Behaviors & Features

Detect and mitigate CVE-2020-2125 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions up to 1.6.11

Fixed versions

  • 1.6.12

Solution

Upgrade to version 1.6.12 or above.

Impact 4.3 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N

Learn more about CVSS

Weakness

  • CWE-522: Insufficiently Protected Credentials

Source file

maven/ru.yandex.jenkins.plugins.debuilder/debian-package-builder/CVE-2020-2125.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:56 +0000.