Advisory Database
  • Advisories
  • Dependency Scanning
  1. maven
  2. ›
  3. postgresql/pljava-public
  4. ›
  5. CVE-2016-0767

CVE-2016-0767: Improper Privilege Management

May 13, 2022 (updated July 28, 2023)

PostgreSQL PL/Java before 1.5.0 allows remote authenticated users with USAGE permission on the public schema to alter the public schema classpath.

References

  • github.com/advisories/GHSA-837x-xww6-7jqm
  • nvd.nist.gov/vuln/detail/CVE-2016-0767
  • tada.github.io/pljava/releasenotes-pre1_6.html

Code Behaviors & Features

Detect and mitigate CVE-2016-0767 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 1.5.0

Fixed versions

  • 1.5.0

Solution

Upgrade to version 1.5.0 or above.

Impact 6.5 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N

Learn more about CVSS

Weakness

  • CWE-269: Improper Privilege Management

Source file

maven/postgresql/pljava-public/CVE-2016-0767.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:10 +0000.