Advisory Database
  • Advisories
  • Dependency Scanning
  1. maven
  2. ›
  3. org.yamcs/yamcs
  4. ›
  5. CVE-2023-45277

CVE-2023-45277: Yamcs Path Traversal vulnerability

October 19, 2023 (updated October 25, 2023)

Yamcs 5.8.6 is vulnerable to directory traversal (issue 1 of 2). The vulnerability is in the storage functionality of the API and allows one to escape the base directory of the buckets, freely navigate system directories, and read arbitrary files.

References

  • github.com/advisories/GHSA-w4m2-qmh3-2g8f
  • github.com/yamcs/yamcs/compare/yamcs-5.8.6...yamcs-5.8.7
  • nvd.nist.gov/vuln/detail/CVE-2023-45277
  • www.linkedin.com/pulse/yamcs-vulnerability-assessment-visionspace-technologies

Code Behaviors & Features

Detect and mitigate CVE-2023-45277 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

Version 5.8.6

Fixed versions

  • 5.8.7

Solution

Upgrade to version 5.8.7 or above.

Impact 7.5 HIGH

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Learn more about CVSS

Weakness

  • CWE-22: Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal')

Source file

maven/org.yamcs/yamcs/CVE-2023-45277.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:00 +0000.